先日突然、連携できなくなっていたWP to Tiwtter。
まさか、bashが原因だなんて誰も思わないよね・・・。

という事でやっと原因がわかりました。

以下のメッセージが出て、SSL通信が失敗するというのが直接的な原因です。
Problem with the SSL CA cert (path? access rights?)

次のサイトに紹介されておりました。
BashをアップデートしたらcURLが使えなくなってた
http://blog.hinaloe.net/2014/09/30/shellshock-php-curl/

apacheを再起動。
無事治り、twitterと連携できました。

bashのアップデートしたら、システム自体を再起動しておくのが一番いいかも。
出来ない場合は、クリティカルになりそうなサービスを、適宜再起動しておくと良さそうです。